FAQ

T3i Magic Codes
Minimum requirements Compatible Android device* running 4.0 and above T3i Operate 2.54 and above Termatrac T3i device with 2.05 firmware and above ...
Thu, 16 Nov, 2017 at 11:09 AM
Syncing a job to Termatrac Online
Requirements: Termatrac Online Account (please contact Termatrac if you don't have an account) Android 4.0+ device  Internet / WiFi connection o...
Wed, 29 Nov, 2017 at 4:14 PM